Hellfire103@lemmy.ca to Programmer Humor@lemmy.mlEnglish · 2 days agoTIFU by not using objects in my object-oriented programming courseworklemmy.caimagemessage-square22fedilinkarrow-up176arrow-down19cross-posted to: programmer_humor@programming.devtifu@lemmy.world
arrow-up167arrow-down1imageTIFU by not using objects in my object-oriented programming courseworklemmy.caHellfire103@lemmy.ca to Programmer Humor@lemmy.mlEnglish · 2 days agomessage-square22fedilinkcross-posted to: programmer_humor@programming.devtifu@lemmy.world
minus-squarevext01@lemmy.sdf.orglinkfedilinkarrow-up11arrow-down1·2 days agoBalls.suck() is the correct syntax.
minus-squareluciferofastora@lemmy.ziplinkfedilinkarrow-up2·2 days agoActually, it would be OOP.suck(ddplf.getBalls())
minus-squareRagingToad@feddit.nllinkfedilinkarrow-up3·2 days agoDon’t you need to declare new Balls() first? Or do you suck() Balls static?
minus-squarexigoi@lemmy.sdf.orglinkfedilinkEnglisharrow-up8·edit-22 days agoBallsFactory ballsFactory = new BallsFactory(); ballsFactory.setSuckable(true); Balls balls = ballsFactory.create();
minus-squarewhats_all_this_then@lemmy.worldlinkfedilinkarrow-up9·edit-22 days agoAll of this is okay, but it’s not production ready. This is what real production code looks like: SuckableFactory suckableFactory = new SuckableFactory(); Suckable balls = suckableFactory .setShape(SuckableShapes.round) .setCount(2) .create(); SuctionProvider mouth = SuctionProvider.getInstance(); SuckerFactory suckerFactory = new SuckerFactory(); Sucker sucker = SuckerFactory.create(): sucker.setSuctionProvider(mouth); sucker.setSuckable(balls); sucker.setIntensity(SuckerSuctionIntensities.medium); sucker.suckSuckable();
minus-squarewhats_all_this_then@lemmy.worldlinkfedilinkarrow-up12·2 days agoPython port: from ballsucker import suck suck()
minus-squarevext01@lemmy.sdf.orglinkfedilinkarrow-up3·2 days agoOr I didn’t using the correct naming convention!
Balls.suck() is the correct syntax.
Actually, it would be
OOP.suck(ddplf.getBalls())
Don’t you need to declare new Balls() first? Or do you suck() Balls static?
BallsFactory ballsFactory = new BallsFactory(); ballsFactory.setSuckable(true); Balls balls = ballsFactory.create();
All of this is okay, but it’s not production ready. This is what real production code looks like:
SuckableFactory suckableFactory = new SuckableFactory(); Suckable balls = suckableFactory .setShape(SuckableShapes.round) .setCount(2) .create(); SuctionProvider mouth = SuctionProvider.getInstance(); SuckerFactory suckerFactory = new SuckerFactory(); Sucker sucker = SuckerFactory.create(): sucker.setSuctionProvider(mouth); sucker.setSuckable(balls); sucker.setIntensity(SuckerSuctionIntensities.medium); sucker.suckSuckable();
Python port:
from ballsucker import suck suck()
Or I didn’t using the correct naming convention!